InnoDB ? whats that . diff.

Devault: I get nothing when I try those, mgriffin

Edgley: Brittman: I tried without the grep part and still get nothing.

Inlow: I am trying to understand if MySQL is smart enough to handle binary logging correctly in this situation. We have bin logging enabled and set to mixed. We’ve defined a trigger that is non-deterministic – it uses UUID. Will MySQL log this change as a row change?

Lumadue: I ask b/c according to the do***entation, “triggers are ***umed to be always deterministic”

Dedeke: Brittman: There is a mysql process running. What am I looking for or should I paste the output on pastie?

Brittman: Dopeelf: eg datadir/hostname.err

Brittman: Dopeelf: iirc that is like lsof show open files on linux

Backers: Brittman: Ah, ok. I have had a peek in that log file but it looks like it works. Last line is “InnoDB: Completed initialization of buffer pool” and then nothing else

Brittman: Dopeelf: what is the time stamp of that file vs system time?

Brittman: Dopeelf: could have been the log you used to use, or is still used

Predovich: Brittman: It’s from 8 minutes ago when I tried to start it last time.

Brittman: Dopeelf: mind pasting the lines since the last “Normal shutdown” in the log to a bin?

Brittman: Dopeelf: or you can use something like iostat or whatever you use for strace to see if stuff is happening

Kovach: Brittman: Sure, no problem.

Brittman: If only mysqld runs here and iostat is busy, you know it is working to start up maybe doing a big rollback

Brittman: Jcotton1123: you can easily check with mysqlbinlog

Brittman: Jcotton1123: you would see the original statement or before/after images of the rows affected

Brannock: Brittman:

Soyars: How to enable multicore support for mysql threads?

Soyars: I notice mysqld just using single core.

Losh: A single query will only use a single core

Dorie: Brittman: It doesn’t look like it’s working at all. Both top and iostat are more or less idle.

Soyars: I see. is possible to make using more than 1 core? i imported big tables. 1gig sql query. but seems not using all cores available.

Keiter: Izham: run queries in parrallel

Soyars: How to do that thumbs

Brittman: Dopeelf: i would check dmesg or something

Keiter: I.e. from a different connection.

Brittman: Dopeelf: looks like something is killing mysqld maybe

Soyars: But the file is single .

Brittman: Dopeelf: when was my.cnf last modified?

Keiter: Izham: are you importing into a single table?

Piccinich: Brittman: Checked dmesg, nothing out of the ordinary, same goes for logs. I can’t find anything that looks “out of order”.

Keiter: Izham: also, how large is that logical backup?

Corke: Brittman: Today, I tried to uncomment “skip-networking”, I’ve used mysql with only a socket.

Keiter: Why would you use skip networking?

Brittman: Dopeelf: revert the change?

Brittman: Dopeelf: preverably you could restore an old copy of the my.cnf maybe you broke something

Soyars: No. im importing into single databases

Brittman: Dopeelf: there are a handful of things you can throw in my.cnf that make it not log things you would expect

Muffoletto: Keiter: The application that uses mysql is local so I don’t see a need to open it up to the network.

Soyars: Quite large . 1G of file size .sql

Keiter: Dopeelf: that still does not warrant skip networking

Brittman: Dopeelf: like malloc-lib where you are missing that so

Keiter: Izham: so you made a large logical dump. You have to wait for it to import, but if you’re using innodb, see:

Digges: Izham: See for common approaches to speed up imports using the InnoDB engine

Soyars: InnoDB ? whats that . diff than mysql?