Chain INPUT policy.

Cagle: Gidwani: Thanks. Seems optimal

Huh: Runa: there’s but I’m not sure the ones that you’re thinking of are still around, since 5.7 includes json natively.

Molder: Snoyes: yep, but I’m still running 5.6 :

Valcarcel: Snoyes: that ones seem to be old, this post mentions a new version but the udfs are not linked from

Mohr: Wonder if sveta took them with her to Percona

Medora: Haha

Pellicone: I ran that and it said I needed 99GB of RAM 😛

Gorney: How is that even the top answer?

Dyce: Scott0_: Only says 1GB for me. But my db is ~300MB

Millin: I am trying to remotely connect to a mysql database on a linux server, either through command line or mysql workbench, but I keep getting connection errors

Bachinski: Thekinginjello: check the connection and service availability from the remote client first. mgriffen likes “nc -v server 3306” because if it is refused, it is firewall, if he gets a banner “host not allowed” it is the grant, banner with no error is probably still the grant

Dahlquist: Tcp failed: No route to host when I run nc -v

Bellman: I can ping the server

Bachinski: Thekinginjello: telnet to that port and see if mysql server responds

Bachinski: Thekinginjello: if mysql server responds, you’re ok with network and firewall. so, what connection error do you get from the remote mysql client?

Florestal: ERROR 2003 HY000: Can’t connect to MySQL server on

Bachinski: Thekinginjello: can you connect locally?

Olkowski: When I try to telnet it says cannot open connect to the host on port 3306: connection failed

Kaai: Connect locally? I have a monitor and keyboard hooked up to the server if that is what you mean

Saik: I am using ssh mostly to access it from my laptop though

Bachinski: Thekinginjello: check the firewall, check whether bind-address or skip-networking is causing issues, then examine the grants for the mysql user that will be connecting remotely, if you’re wildcarding the host in your mysql users then drop any anonymous mysql user accounts

Gang: I checked the /ect/my.cnf

Jekel: I’m not sure how to check the firewall though

Bachinski: Thekinginjello: netstat -ln grep mysql — see what interfaces mysql server is listening on for incoming connections

Gohlke: Unix 2 ACC STREAM LISTENING 14890 /var/lib/mysql/mysql.sock

Bachinski: Thekinginjello: I think you’ll find bind-address set to in my.cnf

Gromer: 2 datadir=/var/lib/mysql

Gambaiani: 3 socket=/var/lib/mysql/mysql.sock

Hejl: 5 # Disabling symbolic-links is recommended to prevent ***orted security risks

Riviera: 9 log-error=/var/log/mysqld.log

Greek: 10 pid-file=/var/run/mysqld/

Lionetti: That is the whole my.cnf file

Bachinski: Thekinginjello: ps aux grep mysql — look for the options p***ed to mysql daemon, see if –skip-networking is in there

Grose: Root 2100 0.0 0.0 108256 1484 ? S 11:47 0:00 /bin/sh /usr/bin/mysqld_safe –datadir=/var/lib/mysql –socket=/var/lib/mysql/mysql.sock –pid-file=/var/run/mysqld/ –basedir=/usr –user=mysql

Dopazo: Mysql 2189 0.0 0.2 377504 23752 ? Sl 11:47 0:01 /usr/libexec/mysqld –basedir=/usr –datadir=/var/lib/mysql –user=mysql –log-error=/var/log/mysqld.log –pid-file=/var/run/mysqld/ –socket=/var/lib/mysql/mysql.sock

Montogomery: Root 5193 0.0 0.0 103304 868 pts/1 S+ 13:21 0:00 grep mysql

Bachinski: Thekinginjello: sudo iptables -L — see if your mysql server computer is running iptables firewall and what its rules are

Kemna: Chain INPUT policy ACCEPT