Jeng: yep need to add both.

Jeng: OK, navigate to wp-content/themes and rename your theme directory to something like mytheme.old. When you do that, WordPress will switch to one of the default twenty* themes.

Gohring: Ok thank you i will do that

Jeng: Pleasedaddy_: for future reference, when you edit stuff, download it to your PC, make a COPY that you keep safe, and edit locally. Push the changed files back to the site via FTP. If you frak up, then you just re-upload the copy.

Jeng: Pleasedaddy_: is the site back yet?

Vogeler: Man this has been a pain in the neck to do

Jeng: What’ve you been up to, fris?

Vogeler: Been playing with the woocommerce + members plugin, and shutting off a lot of the other stuff via filters so stuff is removed

Vogeler: Https://

Jeng: Wow. lots of good snippets there!

Vogeler: You can see it in action here click on the purchase link

Vogeler: If you add it twice also, it will say you cant add a membership twice

Vogeler: And give checkout url

Vogeler: Removed the quantity from checkout so x 1 isnt shown, same with sub total

Vogeler: Need to find the filter for changing the continue to payment to make payment

Vibbert: Yayyyyyyy it worked _ SQUEEE! THX GUYS

Vogeler: Dont think that can be altered unless stripe plugin has a filter

Vogeler: Input id=”payment_method_stripe” type=”radio” cl***=”input-radio” name=”payment_method” value=”stripe” data-order_button_text=”Continue to payment” /

Vogeler: Want to avoid jquery doing it

Everage: Fris, don’t you know why the year field gets removed from the url?!

Gilliom: Hey folks, I’m using ajax to call a wordpress PHP function via ajax-admin.php and it’s working great on my local. But on my ubuntu linux server it’s not playing ball. I can’t see any errors in the app error log, would it put them anywhere else or…?

Jeng: Gilliom: anytahing in the console?

Gilliom: Nope : the php function is returning a 0 rather than a file path it’s generating a pdf so i imagine it’s running into issues but I’ve check permissions etc

Jeng: Do you have all the libraries set on your server to generate PDFs?

Jeng: Gilliom: also, there’s probably a tmp directory involved

Gilliom: It’s mPDF that I’m using. Yep I can view the demo page which means that the libray and it’s dependencies are installed correctly

Jeng: Any AVCs in your SELinux logs?

Jeng: Check /var/log/auditls

Jeng: Sorry /var/log/audit/audit.log

Gilliom: Hmm not that I can see

Jeng: Anything in /var/log/messages or the web server’s own error log?

Gilliom: Jeng: I’ve just tried moving the majorty of the script into a page rather than calling via ajax and accessing it directly and it seems to work

Gilliom: The only bit that I couldn’t test was the postdata, as obviously it’s not now being posted as it’s just happening on page load

Gilliom: Okay this is getting infuriating now. using postman to hit the URL seems to work fine

Waldhauser: How do i make it so on my main navigation , which has text shadowing, to make it so its children ul li a do not inherit that main navigation a property?

Gilliom: Oh you’ve got to be kidding me!

Gilliom: Jeng: it’s because I’m using add_action’wp_ajax_nopriv_generate_pdf’, ‘generate_pdf’; i.e. nopriv because I want it to work when not logged in

Gilliom: Which means that if you ARE logged in it doesnt work, for some reason

Furer: You need wp_ajax_generate_pdf for the logged in users to trigger

Jeng: Gilliom: hoisted on your own petard, as it were

Jeng: Safari: a lot of CSS. :- What’s the URL in question?

Gilliom: Jeng: yep need to add both the wp_ajax_function_name and wp_ajax_nopriv_function_name