I hope you are like BRO a.

Amati: Degroff: lol such is life. I actually dumped the code into my blog set as private. My blog has Edwin but saved code snippets that i never seem to turn into anything lol

Degroff: Well i can’t get wp_insert_attachment to successfully just load an image from a folder i uploaded into uploads

Degroff: Done this 100 times lol and it just won’t work. even copied the code from codex

Degroff: In media library it shows the default media file icon

Degroff: Yet. when i view the URL of hte image it is successfully pointing to the right spot

Tubman: Degroff: so is it maybe not making the small versions. I think media library uses thumb version

Wosher: Make sure the thumb size is being created

Degroff: LindsayMac, yeah i even tried to regen thumbnail too heh

Heatherington: Degroff: and the files are there?

Degroff: I uplaoded /wp-content/uploads/carpet-images/

Degroff: And carpet-images has subfolders etc

Degroff: A csv has the path to the image

Degroff: It worked at one pt but im not sure wtf i did or whats going on 😀

Boudreau: Degroff: and no errors logged or anything?

Degroff: I’ve tried relative paths, full paths heh

Lamanna: And so when you run your script it takes the path to the image you manually uploaded to the /uploads/carpet-images/ directory and basically creates an “attachment” to a post ?

Baris: Takes the path from your CSV

Degroff: I create the product via csv and try to attach the image

Degroff: I did it for a bunch of products already but accidentally deleted the snippet ha

Degroff: It’s only like 130 more products so i could prob just manually load it but feck. i was hoping wam bam

Degroff: Bc the products all get created just have an attached image that has no image available but links to the right spot idk

Troester: Degroff: can you clarify that?

Degroff: Yeah the image that gets attached is the same messed up image as i originally described— where you mentioned maybe no thumbs?

Maalouf: If you look at the img src it is pointing to the right location, and the file actually exists there, but its not showing?

Degroff: Well, the media library shows the default icon

Candill: Degroff: what path does it show?

Degroff: So i guess the url never made it BUT when i go to the media page and click the link to view hte actual image,the image shows

Degroff: But when i click the item in the media tab like i can any other image, the File URL is correct

Sugerman: Degroff: ok on the front end, call the image full and the image thumb and see if either of those show on the front end

Mess: You said 100% for sure that the thumbnail file version exists though, right?

Degroff: No it doens’t exist. when i run regen thumbnails none get created

Degroff: It’s like it points to the image, but doesn’t recognize it idk weird. lemme try to get attachment image src jas

Schappell: Oh ok. I thought you were telling me everyhing was there but not showing

Traxler: Degroff: your issue is that thumbnails arent getting generates

Cariaso: Degroff: are you running wp_generate_attachment_metadata ?

Fulginiti: Degroff: can i see your insert attachment code?

Degroff: Wp_get_attachment_image_src doesnt’ work

Holtz: Degroff: so are the attachments even getting attached to the post?

Raczka: Degroff: i think we’re missing a piece of the puzzle

Degroff: LindsayMac, http://pastebin.com/DDaPd9M4

Degroff: Well the example i showed you doesn’t attach to the post

Degroff: The example i just pasted is just me tryin to add the image to the wp library

Degroff: I hope you are like BRO a semi-colon! and it works lmao