Filipovich: I just can’t.

Filipovich: Cjohnson: it was working until today?

Seman: So I’m trying to figure out where it’s going wrong in the WP app. when I dump the wpdb variable I see all the same details that I used to manually connect, but for some reason when it runs the initial siteurl option lookup, it gets num_rows=0. When I run that exact same query from the exact same details from the exact same server, I get a result

Filipovich: Cjohnson: it was working until today?

Diventura: Yep it was working yesterday

Maenhout: Haven’t done anything to the server. I restarted php5-fpm and nginx for good measure

Filipovich: Soyou know my next question– anything updated?

Rushworth: Nope I manage this server and Kahahane has changed

Munt: Http:// – is there any way to have every product show a price at this page, even if it has variants?

Soula: I have tried the print_error method and made sure suppress_errorsfalse and show_errors

Pasco: The query doesn’t generate an error. I’m in _do_query right now looking at the raw mysqli response

Mansi: You have wordpress with permalinks working on nginx on debian8?

Filipovich: Cjohnson: just for fun. have you rebooted the server? Mysql on localhost?

Jessamy: Mysql is on a percona cluster, and other apps are using it, and everything else works great, plus like I said I can manually connect via those same details

Noyes: I can reboot the app server but rather not reboot the cluster servers

Filipovich: OK. so what might have changed on the percona cluster?

Filipovich: Mysql from WP might not make the same connection as mysql from the command line

Hercher: Kahahane there either. they’re both using tcp according to var_dump$wpdb;

Betterman: Here you can even see it’s making requests just fine:

Potenza: That describe query is getting num_rows = 10

Brakhage: That’s why I’m sooo confused haha

Filipovich: So it connects then borks

Pusch: Has_connected is true even after the bogus query

Spickler: Not sure if that would get updated if the connection dies

Mayshack: But the describe is coming back just fine

Omer: Which comes after the wp_options query

Filipovich: If you run the queries from mysql command line, do you get the right results?

Mayne: Last_error is empty too

Wennersten: Hey everyone. anybody here good at url redirects?

Rosner: Having a bit of fun with a page url and GET request

Filipovich: I’d look at the logs on both servers — SOMETHING had to change. If they’re RH based, I’d look at /var/log/yum.log. Also, the error logs on the mysql servers.

Filipovich: Cjohnson: the logs are probably your best source.

Filipovich: Otherwise, we can guess all day.

Sioma: Thanks for your help Filipovich I’ll keep digging

Stockwell: How to get custom post type WP rest api v2 /posts/ID i get forbiden. any idea?

Bake: I’ve got a custom page template which calls something from a database – WordPress generates an url like: /custompage/?data=mycustomresult – what I want to do is change the ?data= part

Niccoli: Http:// – is there any way to have every product show a price at this page, even if it has variants?

Filipovich: CMFDesign: you want to show prices on the grid for each product *and* its variants?

Filipovich: Three should be some hooks for this.

Scharber: Filipovich: so if the range is £100 cheapest to £400 most expensive then I want it to say £100 – £400

Filipovich: CMFDesign: exactly what I was going to suggest

Demel: Filipovich: I just can’t figure out how to get it to display that