Checked the slack channel.

Begonia: Degroff: why are you doing this $wp_upload_dir’url’

Meara: Why not just wp_upload_dir

Degroff: Wp_upload_dir returns an array, but what’s there is copied from code

Corrio: Ok. i didnt know it created an array

Degroff: Yeah i forget it does sometimes :

Degroff: Permissions all check out. i have a sister folder next to it that had worked just fine but i guess i ran a dif script.

Kimak: Degroff: so again to be clear. it’s creating an ‘attachment’ post for every image you’re creating as an attachment. In the media library the thumbnails show as default and there are no thumbnails or other sized versions in the directory HOWEVER in the attachment view in admin if you click on the attachment source it has the correct path to the image, correct?

Degroff: Yeah the File URL textbox has the full URL to it

Degroff: If it helps, wp_generate_attachment_metadata is returning an empty array, LindsayMac

Degroff: That’s probably the culprit

Moyer: Degroff: i am pretty sure you have to include ‘ require_onceABSPATH . ‘wp-admin/includes/media.php’;’ after you include image.php as well

Degroff: LindsayMac, ok i will add that, however i also found this:

Degroff: Wp_check_filetype returns array2 { “ext”= boolfalse “type”= boolfalse }

Rainwaters: Degroff: ahh oh. thats not good

Klusmeyer: Degroff: I have read that you can check filetype with the path or the file name.

Degroff: Yeah i tgried the fiull path too

Degroff: Im hard coding image/jpeg to see if it works

Degroff: Now that i hard coded the type, the image shows up as a tiny 1×1 dead oimage maybe? it’s empty but def not the image itself

Degroff: I try to regen thumbs and it says :”Balsam” ID 1361 failed to resize. The error message was: The originally uploaded image file cannot be found at /home4/user/public_html/wp-content/uploads/carpet-images/1st Place/Balsam.jpg

Degroff: And i’ve tried paths withou any space too

Stevey: Degroff: omg you have SPACES IN YOUR FILE NAMES?!

Surprise: Degroff: oh no no no no

Degroff: LindsayMac, yeah i didn’t realize at first BUT.

Degroff: The first 200 products i loaded have at least 50 with spaces and it worked fine lol

Degroff: Plus i ran it on a path with no spaces

Robuck: Yea well. thats REALLY bad

Vitale: It muddies the water intensely

Degroff: OK well this whole thing is full of sample products anyway, so it’s all going to be whacked

Degroff: I’ll be sure to run those thru and remove spaces heh

Degroff: Once i get the actual products :

Zasso: Yea definitely do that

Degroff: Before I do that i need to figure out wtf is going on with this import

Degroff: I was given a dropbox of images and a spreadsheet and told this is sample data to enter and destroy later lol so i just ran with it

Yonemura: Its initially what i thought it was I think

Degroff: Yeah it’s not though bc i thought it was too haha

Furlow: Degroff: $wp_upload_dir’url’ should be $wp_upload_dir’basedir’

Degroff: Then i went and saw all these products that had images ATTACHED to them

Degroff: LindsayMac, i just changed url to baseurl bc i realized url was giving hte date

Degroff: Literally JUST did that haha

Degroff: Now what’s happening is the iamge is a 1×1 image for some reason

Wittenborn: What do you mean giving the DATE?

Degroff: Lemme regen thumbnails

Rehman: Hi all. is here anyone with access to the forums. yesterday my account had been flagged for 24 hours. From what I can tell it is still in moderation after the 24hr period. Could someone check and give an update?

Vancooten: Checked the slack channel and everyone seems to be asleep