Once I import the.

Grosclaude: This is the migration file http://paste.ubuntu.com/12520147/

Swed: Absklb, but if the trace shows the exact statement being executed, then the {{user_remote_identities}} should definitely not be there – should be replaced with real identifiers

Klafehn: My mysql version is mysql Ver 14.14 Distrib 5.6.25, for debian-linux-gnu x86_64 using EditLine wrapper

Connon: Second laptop mysql version is ,mysql Ver 14.14 Distrib 5.5.44, for debian-linux-gnu x86_64 using readline 6.3

Selzer: Swed, i dont understand how it worked in my first laptop?

Rumphol: Swed, whats actually wrong? how can I solve it?

Bingham: Absklb, not a mysql error, it is your script and its variable

Swed: Absklb, badly configured migration tool or something? try asking the framework channel if there is any

Toddy: If I have a table with 50 products in it, and I run an import to update 30 of those. but I want to update the other 20 to appear out of stock by updating a field to ‘0’. How would I tell the import to set a specific field to ‘0’ if not imported?

Swed: Marcosis, may depend on how do you import – you can set all to 0 at the beginning of your import script if the updates then change it to a real value

Shinkel: That is true. I am updating a table from a table within the same schema

Suhar: I have a transaction waiting on this lock: ‘RECORD LOCKS space id 0 page no 867 n bits 144 index PRIMARY of table mydatabase.mytable trx id 1F4B6 lock mode S locks rec but not gap waiting’. Does that mean the primary key’s index is locked?

Abelman: Marcosis: Icf you’re doing that, you can just update using am outer join and then use COALESCE to 0 for the missing cases.

Porowski: Marcosis: It’s not an import or doesn’t need to be, correct?

Alstad: Xgc: I’m importing to a table, then dishing that content out to multiple other tables updating only specific fields

Huttar: Marcosis: That’s fine. Then you can just set the missing rows to 0 via an outer join used to update for the both the existing rows and missing rows.

Correl: Marcosis: Normalizing. Sounds good :

Kine: Nice, that helps me a lot 😀

Bauder: Salle: Just trying to keep my sanity at this point 😛

Hanisch: Chasing sanity is never a good idea.

Choy: Brittman: can I ask you some

Mody: When MySQL shows output as following http://picpaste.com/character-collation-lg6A5o46.png should the next new table created not be automaticly InnoDb with utf8mb4_unicode_ci as Collation?

Memmott: Depends on what was current when the database was created

Boes: Oooh, so it will only be affective on NEW db and not on existing db with new tables

Harwell: Yeah. You can alter the existing db though.

Schrimpf: Https://dev.mysql.com/doc/refman/5.6/en/alter-database.html

Economy: Snoyes: you mean like ALTER TABLE our_tablename CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

Catlin: I mean like ALTER DATABASE CHARACET SET utf8mb4;

Ledford: Then, ***uming you spell “character” correctly, new tables will inherit that

Marron: I linked mysql and tomcat docker containers with eachother but my web application cant find db, tomcat says ” Caused by: java.net.ConnectException: Connection refused ”

Frisch: Update xxxxx_virtuemart_products_en_gb left outer join import using virtuemart_product_id set xxxxx_virtuemart_products_en_gb.virtuemart_product_id = import.virtuemart_product_id; returns 0 affected, 0 updated and 0 warnings even though table “xxxxx_virtuemart_products_en_gb” is empty and “import” has over 4000 lines. What am I doing wrong?

Correl: Marcosis: UPDATE can not insert new rows into empty table

Correl: Marcosis: Only INSERT can insert rows.

Correl: Marcosis: If the table is non-empty you can use INSERT . ON DUPLICATE KEY UPDATE .

Bighorse: So if I wanted to update and insert new rows, how would I accomplish that?

Sleeman: Once I import the information I want to then update current information and add new information if the ID is not found