Brittman: I am using a.

Copier: Results of what I’m seeing.InnoDB is locking up, with about 400 transactions in “flushing log” state for 2-13 seconds

Copier: Symptoms don’t look like InnoDB checkpoint flushing

Danfield: Laurentide: mysqlselect version;

Brittman: Laurentide: while 2002 wont be solved, i would fix the client problem first which might be the set thing. which distro?

Gamma: Sorry i’m not exactly an expert. some output from mysql status;

Ageboi: Mysql Ver 14.14 Distrib 5.5.33, for Linux x86_64 using readline 5.1

Treinen: Server version: 5.6.25-73.1 Percona Server GPL, Release 73.1, Revision 07b797f

Brittman: Laurentide: which linux distro do you use?

Brittman: Laurentide: i would pastebin something like: rpm -qa grep -i ‘mariamysqlpercona’ && yum repolist

Copier: Laurentide: basically what you’re experiencing is a version mismatch between your mysql server and your mysql client packages.

Copier: Fixing that should resolve the issue.

Copier: Holy ****.that’s the issue. Someone changed that on me.

Copier: Innodb_log_file_size = 1999634432

Copier: And sorry for cursing. -.-

Copier: I set that originally.don’t know how it got changed. But that’s certainly the cause. flushes must be gigantic.

Magwire: Brittman,

Copier: Brittman: yeah, I’m just imagining maintaining a 40% LRU on a 2GB logfile.

Nehlsen: I have learned ‘diffable schema’ is ‘mysqldump -A –no-data –skip-comments sed ‘s/ AUTO_INCREMENT=0-9* / /g”, as a factoid

Brittman: Unless someone else has a better solution

Brittman: Copier: hm. which package owns the running mysqld? maybe something like: rpm -qf $ps axuw awk ‘$11 ~ /mysqld$/ {print $11}’

Brittman: I would expect “Percona-Server-server-55-5.5.33-rel31.1.566.rhel6.x86_64

Brittman: And that you connect to some other server, or have multiple instances, or things like that

Havermann: Ok, thanks all for the information

Brittman: Laurentide: you might even cat /root/.my.cnf or /etc/my.cnf and see if client or mysqldump has a host defined that you didn’t expect

Huges: Nothing looks out of the ordinary in my.cnf

Copier: Brittman: I think you meant that last tag on me for laurentide. 😛

Brittman: Laurentide: also open “mysql” and issue the command “s”

Brittman: Laurentide: look at Connection and socket lines

Brittman: Anyone know how to strip AUTO_INCREMENT= from mysqldump –no-data without sed? didn’t see a switch for it in man

Brittman: To improve the factoid i just created

Mesaros: The thing that really stands out to me in mysql s is that the mysql version and the serrver version are different

Brittman: Laurentide: the thing that bothers me is server runs 5.6 yet nothing in rpm indicates that should be true

Brittman: Laurentide: is mysqld running in ps? where is this binary? are you connecting to the expected host?

Brittman: Maybe you just did a /usr/local install from tar or something, not enough info yet

Arambuia: Seems like the sql server is running on a differnet server, which is why i have to use -h ?

Brittman: Laurentide: run mysqldump on that server, or upgrade your local client binaries on this server

Irland: Is it possible for a query say select 1 to take less than 1 microsec?

Brittman: Laurentide: tlrd, you were exactly right but didn’t tell us there were two servers involved

Brittman: Xor1: use ping instead? wait, what are you asking?

Sehr: Well. indeed solved the problem and i learned a lot

Brittman: Laurentide: why are you running mysqldump manually?

Devere: Brittman: I am using a trigger to keep track of table for client polling data. As of now, I am using micro sec precision. For two close update/insert it is possible that the change might not be noticed because the timestamp is the same