Also, in mysql 5.6 how can.

Alconcel: Izham: explain your problem then more specific information can be gien.

Capizzi: Help my server isn’t working can someone help?

Danfield: Have you tried turning it off and then on again?

Capizzi: Keiter: I was just trying to fit in! 😛

Sechrest: Keiter, i’m going to join a ml for this.

Rohlack: How do I get mysqldump to prepend BEGIN TRANSACTION and suffix COMMIT in a dump – the entire dump?

Veller: Does your dump contain “create table” and other DDL?

Harnett: Why is this a requirement? what is your goal?

Harnett: Moutoux: fixed values can come from the app, the rest can be from other tables as per a select statement. Looks like you are denomalizing at this stage and that may not be a good idea.

Moncus: Veller, yes. I am doing a dump, not restoring

Scaturro: Veller, I want to ensure that my restore is done fully atomically

Poindexter: Veller, how can I do that

Veller: Milos, but the transaction management which you want written in the dump would only be used during restoring, –single-transaction takes care of taking consistent dump if your tables are innodb at least

Gorny: The problem is I don’t see any transaction stuff in the output, –single-transaction or not, the output is exactly the same

Veller: Milos, and “atomical” restore is not possible afaik – in mysql DDL creates/drops/alters are not transactional so you cannot just wrap them in a transaction

Veller: Milos, yes, that is the purpose – mysqldump uses –single-transaction when RUNNING the dump – the selects it uses to generate the dump, it is done in the background but does not change anything about the structure of the data output

Bless: Show slave status is showing — Last_SQL_Error: Error ‘Out of memory Needed 8390432 bytes’ on query. Default database: — What memory is this ? how do I give it more memory. I don’t think its using available RAM

Holian: Innodb_buffer_pool_which_var_?

Timmermans: Have you tried to google that error?

Lominack: Probably none of above

Rankhorn: Yes, been googling also

Routhier: Haris: can you post the last few lines of mysqld error log?

Routhier: Maybe anything since the string “sock” appears

Routhier: Haris: also which version of mysql on the slave?

Scheid: Aha! Why didn’t I check log beore

Yegge: 150923 19:53:44 Warning Slave: Out of memory Needed 8390432 bytes Error_code: 5 — and on next line — 150923 19:53:44 Warning Slave: Got error 12 from storage engine Error_code: 1030

Routhier: Haris: is the table in question a memory/heap table?

Tonnessen: I’m not sure. I thin its innodb

Benoit: Correction: MyISAM type temp table

Routhier: Haris: try “stop slave;” then “start slave;” to see if it was a transient error

Routhier: Haris: and/or figure out where you have misconfigured something

Everson: Done that too many times alraedy. happens every time

Emling: Comparing with master/other slave

Pelkowski: I doubt if I can change innodb_buffer_pool_size. up’ing which of these would help — key_buffer_size + read_buffer_size + read_rnd_buffer_size + sort_buffer_size + join_buffer_size X max_connections

Tilus: Change innodb_buffer_pool_size without restarting mysql

Cutri: Innodb_buffer_pool_size is 2GB on the other nodes. and it works fine

Mankey: Here, its not working

Carlucci: When creating a new table with a datetime field, is there a way to say to automatically cast invalid date times to datetime?

Gurganious: They’ll be cast to 0000-00-00 if that’s allowed.

Gurganious: Depending on just how invalid they are

Gurganious: And depending on your sql_mode

Gasperini: Also, in mysql 5.6 how can i properly rename a database?