Switch would probably be.

Szychowski: Hahaha _TWG_ you can just ask the channel.

Szychowski: Including Ihm usually.

Zola: I made a small change to my HTML markup yesterday and now the code you helped me with no longer works. http://kopy.io/POEUI

Moreman: Szychowski: the only reason I asked him was because he was helping me yesterday.

Comee: When I click the item to toggle my list, it no longer toggles.

Xayavong: I wasn’t sure how to make it look a level up.

Szychowski: I’d .closest’li’.find’ul.tree’ or something along those lines.,

Prime: Dang Szychowski you are the man. That fixed it right up. Thanks for the help.

Szychowski: You should check out learn.jquery.com btw :

Szychowski: Some great tutorials that cover topics like this.

Thongdy: I do plan on it. Thank you for the reference.

Dennett: Hi all basic jquery question

Winesickle: If I do something like $’li a’ I get all the a’s nested under li’s

Abegg: How do I get the nth one?

Lazaga: Ihm: So $’li a’.eq3 for instance will give me the third?

Ihm: And it will be of the result set, not guarenteed to be all of the same parent, if that is a concern

Massingale: Hmm I’m having an issue now though

Stirling: I’m trying to modify certain input elements

Drakos: Works fine, changes all inputs to ‘test’

Couey: But $’td input’.eq0.val’test’ doesn’t work

Ihm: If the first works, that one should work as well

Maohu: No, console seems to be returning the dom node from what I can tell. n.fn.n.init {0: input, length: 1, prevObject: n.fn.n.init, context: do***ent, selector: “td input.slice1,2”}0: inputcontext: do***entlength: 1prevObject: n.fn.n.initselector: “td input.slice1,2″__proto__: Object

Szychowski: Dunno then. should work fine.

Ihm: Wait, is that a slice in the selector?

Szychowski: Siegfried show us your real code maybe?

Froning: Szychowski: $’td input’.eq0.val’test’

Whyard: Just running it on the console

Szychowski: And your markup is valid?

Loeser: Szychowski: As far as I can tell

Ahlfield: I think there are hidden inputs

Decesare: Cause 4 5 6 are working on what I thought was 0 1 2 😀

Ihm: Cl***es on what you want to target are a good thing, ;

Afflick: Ihm: This website uses no cl***es or ids ;_;

Ihm: You writing a greasemonkey script or something?

Dronko: Ihm: No, writing a script to help me enroll for the cl***es I want at my uni 😀

Radway: It’s currently full but when someone leaves a spot opens up to the first person to nab it

Ihm: Damn, that’s committment

Mcspadden: Can someone help me refactor this. it isn’t very dry. https://gist.github.com/anonymous/b9aeba60dfeffc45daed5fd30e6ceffa

Ihm: Store the common parts in variables

Szychowski: An use bettr nesting.

Ihm: And the ‘else’ keyword is also available

Ihm: It looks like “actionDatearrayFromPHP getDateTime” is common to them all, so that’s like the outer most if.

Szychowski: Https://bpaste.net/show/554ee4cd9ea8 something like https://bpaste.net/show/554ee4cd9ea8

Szychowski: Oh i messed up the completiondate nesting.

Szychowski: Either way, you can and should do that.

Szychowski: Also, cal1, call2, call3 etc – why not have one var that holds the value you care about?

Ihm: You could also do an array and do an indexOf to avoid some of the if elses

Szychowski: Just need to better structure your data.

Ihm: Would shrink it considerably

Aiudi: Switch would probably be more readable