However, the function will.

Lapatra: Okay I can’t figure this out from Google.

Lapatra: I am trying to select a SELECT element by its ID. How do I do that?

Lapatra: A lot of Gogle examples speak of using .find, but that function doesn’t exist per Chrome.

Lapatra: Maybe I’m going aboutthis wrong. I selected my SELECT object, but am not sure how to determine the individual selected OPTION objects. How does that work?

Calligy: Lapatra: you want to get the value of the selected option?

Sechrest: Lapatra: ***uming your select has an id of select, you want $”#select option:selected”.val

Biscoe: What do you people think about photoswipe?

Lapatra: Hurry: that certainly works, but can I go from the selected object to the sub-object? Not sure if my terminology is correct

Snith: Lapatra: define sub object

Lapatra: Hurry: sure. So I started by selecting the entire SELECT as follows: control_pool = $’#control_pool’;

Lapatra: Now, from control_pool, can I specify an individual option element?

Mishra: A selected option element?

Lapatra: It doesn’t have to be, I would prefer to iterate through them.

Bowlet: If I understood you correctly

Lapatra: How do I iterate throught hem?

Tefertiller: Hello! Anyone can help me with some JQuery? My code doesn’t work and idk why :S

Outley: Btw, I need some thlp too

Parady: So this is my code :

Gaines: Idk if I did it the good way but I am trying to add images to a UL

Cavness: Http:// — why don’t $”#loginHolder”.text and $.mobile.changePage work?

Hildahl: Olidac: first, you’re doing .append on the id string: .attr’id’.append. which is wrong, strings don’t have a .append. just remove that .attr’id’

Dehne: I removed it and it still doesn’t work :S

Maresh: Olidac: and 2nd, you’re doing the append outside of the getJSON callback, so it happens much before the getJSON callback is called. just move the append to be inside the callback

Excell: Ok so I made the changes and it’s still not working XD maybe because I use Foundation?

Jeans: I donno, maybe because you’re not using jsonp correctly for however your serverside is configured

Santilukka: Server must specifically allow jsonp

Santucci: Oh the server is reddit so.

Argenbright: But i don’t think jquery looks for a jsonp=?

Nowicki: It looks for callback=?

Vanschoyck: But reddit doesn’t like that

Lansberg: So you can use $.ajax with more specific settings

Gladu: Http:// — why don’t $”#loginHolder”.text and $.mobile.changePage work?

Sperazza: Shoky_ : this one works but I want to use it so its in a UL list.

Moscoso: Olidac: oh so its ok with jsonp=?

Brigner: Olidac: anyways this works too

Hannam: It doesnt work on jsfiddle cause jsfiddle is on https and the reddit url isn’t

Rundle: Works on jsbin,js,output

Almy: Ah ok XD I will try it : Thanks!

Connon: What was the error/problem?

Gilhousen: You didn’t show yours after fixing those 2 errors

Presnal: Question folks. Why does the jsonp server still sends the response to our jsonp request even if we have canceled our request via timeout period?

Newham: Zumba_ad_ either there was a request or there wasn’t.?

Kuklinski: If there was, then there may be a response

Mascia: What’s the problem ;p

Hembre: It responded after the timeout period

Buczak: And if jquery canceled it, it would go inside error: callback

Slark: However, the function will still be called giving us a Uncaught TypeError jquery2352533252_823489237943724 is not a function