Guessx: roger that. Had to.

Weisenberg: I might have successfully rubber-ducked

Deshpande: Unkis, monk3y: that was is, made it to the next error! thanks a lot guys, gonna crash now. this was keeping me up lmao

Trevey: The development of bug fixing process: a new fix = 10 new bugs

Quance: Tash: once you’ve closed-off the do***ent.ready binding, just a general HTML/CSS note: you might want to replace those ‘cl***’ identifiers with IDs. If they’re single/unique elements in your do***ent, it’s clearer to use IDs

Weisenberg: Uhkis and monk3y: I actually did have the closing }; but I just didn’t have it pasted. It was below some comments that I just didn’t paste.

Weisenberg: But back to square one, the button seems to not work as I’d expect. Not even getting anything in console with my console.log

Heines: Hmm k. Would you mind throwing in a debugging thing; $”body”.on”click”, functione {; };

Mcglothian: Something like that. Then refresh and click the button, and see what the console log tells you about the element clicked.

Weisenberg: Sure, np, just put in my do***ent.ready?

Lakin: Yep; in-line with the .get and .click.

Padlo: You should see it console.log for clicking anywhere on the page.

Weisenberg: This is what the console logs when I do that: button id=”113029″ cl***=”ack”

Weisenberg: Which is what I’d expect

Whitmore: When I closed off your do***ent.ready in the JSFiddle, it ran and the button did what it was supposed to showed the console.log talking about the note/noteID

Kenyon: I didn’t make any other changes than closing it off. Is your local code in any way different from the JSFiddle?

Weisenberg: For sanity’s sake, this is what my code looks like right this moment:

Weisenberg: And the only thing logging is what I just replied with a few minutes ago after adding your debug line. I’d also expect to see “the id of this note is ” + whatever noteid is” but I’m not.

Chasser: And have you got any errors in your console that might indicate your script is breaking anywhere? As in, if it is breaking anywhere before the, then it won’t register or listen

Weisenberg: Nope, checked there, I’m not getting any errors in my console =

Weisenberg: Guess in my fiddle I was doing huh? I tried ‘button’.click too . should I change that back to .ack?

Weisenberg: The current code is ‘button’.click

Weisenberg: Hold on, I might have found the issue.testing something

Acy: It can be either. If you have several buttons then go with the cl***es, otherwise give it an ID and $”#buttonId”.on”click”, etc.

Verdejo: And .click is a shortcut for .on”click”.

Weisenberg: In my case, I shouldn’t have too many buttons. I’ll give it an id

Chauca: Hmm. Try updating with this; $’button’.clickfunctione { var noteid = .

Haltom: I’m not 100% sure about it, just trying different approaches to the same result.

Burtell: Have to go afk, will be back.

Weisenberg: Tried the last suggestion, same result.

Weisenberg: I gave the button id=”ackbutton” and my jq looks like this $’#ackbutton’.clickfunctione{ var noteid =; console.lognoteid; . yet nothing is logging

Weisenberg: Latest code: anyone else see anything wrong?

Weisenberg: Monk3y: it definitely has something to do with the way my .get is returning stuff. The .get call to ./modules/notes_v2.php. when I comment that block of code out, and just statically put content in that it creates, and click the button, works fine.

Needleman: You use to be able to use .live, now its .on’click’, elm, func

Weisenberg: Guessx: I was wondering about the new content thing. What does elm mean in your example?

Mccosker: So in your case on’click’, ‘.ack’ func

Hamlin: Guessx: roger that. Had to step away for a minute but will try in a few minutes.