Unless this is gonna run.

Sharplin: Kamuela_iOS: the thing is, I’d like to remake an old website that was done 6 years ago, that’s all static

Reekers: If you use pushState routing you _should_ be ok

Levian: Ideally, I’d like to use something like Angular more as a learning experience than anything else, because I already know React

Griess: But I’m afraid to ***** it up

Smoots: Right now, it’s number 1 on Google

Schurkamp: For all the relevant keywords

Pourvase: It’s not a project with a deadline

Pliler: Kamuela_iOS: ok, thanks

Pickering: Well you’d better do your research beyond what I’ve said

Feerick: I hate writing the keyword soup part of resumes

Feerick: I never know what is important enough to keep and leave out.

Lust: After you figure it out just give me a copy so I can change the name at the top

Millerbernd: Resumes are a pain in the ***. I wish LinkedIn did a better PDF export

Feerick: I dont have a linkedin because **** linkedin

Holstine: It’s been getting jobs for people I know for a long while actually even before it was well known

Feerick: Yeah i guess. whenever i’m contacted by recruiters its for **** i don’t care about

Sirin: Is there a better version of LinkedIn for developer jobs? I know there’s dice but that hasn’t helped me much yet. Its mostly US and I’m presently in the UK. Thoihh

Shawver: Though I would remote

Provenzo: Which’s better: a if xor { out.writeUint32last = ac; } else { out.writeUint32ac; }

Falconeri: Or b out.writeUint32last = last & xor ac;

Feerick: Please dont write code like that

Feerick: Both of those are bad

Feerick: The compiler will make both of those equivalent.

Feerick: And most variations of it

Marfil: Tcsc, well it is a 1:1 port from ***embly

Feerick: This is basically never how manage to make js programs performant.

Donlin: I’m just trying to make it shorter now

Yocius: And thus more readable

Feerick: Don’t ***ign in a function parameter.

Feerick: Those aren’t the same.

Pae: Shorter almost never means more readable

Feerick: More readable code is often shorter, but just making your code shorter for the sake of it will not make it more readable

Wehrsig: Out.writeUint32last = last & xor ac; is IMO better than last = last & xor ac; out.writeUint32last;

Feerick: Well, it’s subjective, so I can’t say you’re definitely wrong. but i dont know anybody who has done a significant amount of programming who would agree with you

Grillot: Far less readable and less readily apparent to another developer coming into it with fresh eyes, I’d say, but yeah this stuff gets real subjective

Yant: Yeah that would earn a ಠ_ಠ or two in code review

Kahawai: Well what matters is how well the minifier can minify it

Fantz: Aka how fast it’ll load

Almgren: Umm, the minidisc will do it’s thing

Meszaros: The minifier is stupid

Yant: Soni: get a smarter one :

Rothrock: Dash, no sane minifier can infer that xor is only ever 0 or -1

Reisert: Mainly because it’d have to look thru the whole dependency chain

Nappi: Including p**** idk how many bytes of jQuery

Yant: I wonder if closure compiler can do that

Feerick: If you have jquery included any arguments you have involving ‘i want to save a couple bytes here’ are basically invalidated.

Feerick: You’re talking like less than 1% of your download time

Rizor: The amount of minification on something like that is gonna be negligible even without jquery

Rizor: Unless this is gonna run in, like, the voyager 2